const regex = /((https(?:s)?:\/\/)?(www\.)?)?(?:youtu\.be\/|youtube\.com\/(?:embed\/|v\/|watch\?v=|watch\?&v=))((?:\w|-){11})((?:\&|\?)\S*)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((https(?:s)?:\\\/\\\/)?(www\\.)?)?(?:youtu\\.be\\\/|youtube\\.com\\\/(?:embed\\\/|v\\\/|watch\\?v=|watch\\?&v=))((?:\\w|-){11})((?:\\&|\\?)\\S*)?', '')
const str = `https://www.youtube.com/watch?v=5rhX7PepzaU`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}