package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i):([^\s:]+):`)
var str = `:any-non-whitespace:
:text1:sample2
:@(1@#$@SD: :s:
:nospace::inbetween: :because there are 2 colons in the middle:
:nospace:middle:nospace:
: :
::
:::
::::
::j::
:j:k:
:j:k:l:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}