import re
regex = re.compile(r"^(\s\w|\s\s)\s{2}(\w{2}\d{2}PRI)((?:\s+\d+)+)", flags=re.MULTILINE)
test_str = (" Device FT01PRI FT02PRI FT03PRI FV01PRI FV02PRI \n\n"
" F AD01PRI 0 0 0 0 0 \n"
" R CX01PRI 0 3 0 3 6 \n"
" O CX02PRI 2 2 1 0 0 \n"
" M CX03PRI 2 0 1 1 6 \n"
" DA01PRI 0 0 0 0 0 \n"
" DA02PRI 6 0 0 0 0 \n"
" DB01PRI 0 0 0 0 0 ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)