$re = '/[A-Za-z.-]+@[A-Za-z.-]+/m';
$str = 'Hello,
I may openly talk about this@that.com
and also mr.nobody@some-thing.org
but thanks to the website administrator email addresses will be redacted to a uniform length. That way you realize that this was an email address but we leave no clue whatsoever about username, domain name or ending.';
$subst = "██████@██████.███";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;