re = /(\w+(?:\.\w+)*)\s*&&\s*(\1\.\w+)\s*&&\s*\2\.\w+/m
str = 'one.two && one.two.three && one.two.three.four'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end