$re = '/(?(?<=^|\s)\p{P}|\p{P}(?=\s|$))/m';
$str = 'hey, have you tried example.com? it\'s got cool things.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);