const regex = /[^0-9-\s]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^0-9-\\s]', 'gm')
const str = `90210
02134
12345-6789
H0H-0H0
SOUTH DAKOTA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}