package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z_0-9]+$`)
var str = `Username`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}