$re = '/[0-9]{2,3}/';
$str = 'The number was 9.9997 but we rounded it off to 10.0.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);