package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<cc>\w+@[^\"]+)`)
var str = `"cat@gmail.com", "ant@gmail.com", "sat@gmail.com", "mat@gmail.com"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}