import re
regex = re.compile(r"(?<=\*{6}\s)(?=.*B{3})[^(?>\*{6})]+", flags=re.MULTILINE)
test_str = ("Some text here AAA\n"
"Some text here One\n"
"Some More text here\n"
"******\n"
"Some text here BBB\n"
"Some text here Two\n"
"Some More text here\n"
"******\n"
"Some text here CCC\n"
"Some text here Three\n"
"Some More text here\n"
"******\n"
"Some text here BBB\n"
"Some text here Four\n"
"Some More text here\n"
"******\n"
"Some text here BBB\n"
"Some text here Five\n"
"Some More text here\n"
"******")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")