$re = '/E(\d+)E/m';
$str = 'E123ExxxE456E789E';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);