package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\{\(\[]?(?P<studio>.+?)[\}\)\]]?([\-\ ]{2,3}|\]\s)(?P<clip_name>.+)`)
var str = `[studio island mredia] - name
studio island - namde
(studio name) - clip nsme
[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean
[falcon studios] - out of athens
[falcon studios] out of athens
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}