import Foundation
let pattern = #"[|]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"|陳|林|黃|張|李|王|吳|劉|蔡|楊|許|鄭|謝|郭|洪|邱|曾|廖|賴|徐|周|葉|蘇|莊|呂|江|何|蕭|羅|高|潘|簡|朱|鍾|彭|游|詹|胡|施|沈|余|盧|趙|梁|顏|柯|翁|魏|孫|戴|方|宋|范|鄧|杜|傅|侯|曹|薛|丁|卓|馬|董|唐|藍|蔣|石|温|古|紀|姚|黄|連|馮|歐|程|湯|康|田|姜|汪|白|鄒|尤|巫|鐘|涂|阮|龔|黎|韓|嚴|袁|金|童|陸|夏|柳|凃|邵||錢|溫|伍|倪|于|譚|駱|熊|任|顧|甘|秦|毛|史|章|萬|俞|官|雷|饒|粘|張簡|闕|崔|尹|凌|孔|歐陽|辛|辜|易|陶|段|龍|葛|韋|池|孟|殷|褚|賈|賀|麥|管|莫|文|關|向|包|武|丘|范姜|華|梅|樊|利|房|左|佘|魯|安|鮑|花|郝|全|穆|邢|塗|蒲|成|常|谷|耿|盛|練|鄔|聶|祝|曲|解|繆|齊|申|閻|岳|符|龎|應|籃|裴|陽|單|舒|牛|喬|畢|翟|鄞|季|留||卜|塗|覃|喻|項|滕|焦|商|買|車|苗|戚|虞|牟|臧|力|樂|雲|樓|艾|費|巴|司|屈|宗|尚|靳|桂|諶|衛|宮|祁|欒|髙|沙|路|幸|刁|時|柴|瞿|閻|談|隋|柏|竇|鄺|查|霍|閔|吉|冉|遲|仲|鄂|仇|儲|松|龎|湛|東|風|榮|匡|婁|冷|甯|卞|裘|昌|晏|桑|顏|席|初|岑|邊|叢|禇|郁|姬|偕|蘭|蒙|兵|區|勞|郎|甄|奚|屠|聞|景|鞠|明|佟|釋|周黃|米|伊||荊|厲|茆|机|盤|原|封|干|才|錡|粟|江謝|容|標|平|皮|宜|宣|竺|茅|藺|鄢|司徒|蓋|敖|張廖|芮|黨|冼|寇|苑|候|惠|貝|栢|危|狄|於|南|禹|胥|嵇|杞|枋|烏|逄|諸|師|岩|楚|鹿|修|農|浦|哀|欉|城|來|戎|翁林|月|豐|那|甯|強|忻|滿|覺|関|姜林|都|支|帥|闞|戰|宇|晁|濮|元|郜|燕|井|朱陳|雍|寧|廉|束|相|鈕|絲|上官|酆|森|鞏|永|揭|慕|計|薄|麻||栗|杭|富|壽|卿|斯|羊|戈|印|居|邴|班|陳李|哈|張陳|普|權|門|張李|邱黃|賓|林吳|亓|日|陳黃|漆|冀|王李|李陳|端木|衣|祖|爐|綦|卯|酈|根|閆|葉劉|乃|步|矯|國|姬|念|招|臺|資|李林|仝|苟|璩|寸|秋|達|薩|尉|展|栁|水|陳吳|諸葛|經|索|扈|山|嘪|宓|甯|鳳|扶|勵|豆|和|海|邰|墜|角|劉黃|衡|肖|昝|隆|伏|貢|同|英|過|茹|味|銀|曠|邸|豊|公|眭|糠|宿|沃|字||但|楓|閩|出|盂|信|紅|赫|湖|巖|陳許|敬|蒯|闗|習|漳|操|廣|褚|侍|晋|堯|邜|阮呂|皇甫|霜|滑|劉張|生|朴|洗洗|晉|况|李黃|張許|巢|周|登|書|勤|依|陣|掌|黑||玉|由|廉|藩|宛|郗|三|法|洋|承|禚|磨|閉|唐|丹|哖|延|禤|亢|巧|阿|翼|邦|虎|陰|靖|沐|訾|鮮|歸|桞|剛|望||李王|王吳|別|衷|奉|青|保|毒|母|渠|刀|勾|郭李|蘇陳||毋|律|慈|巨|呼|番||鎖|徐陳|冒|徐辜|歐李|階|糜|焉|么|世|冬|雙|鐵|布|年|逯|言|玲|咸|須|王劉|仰|稅|張楊|蔡黃|位|壯|從||刑|庄|謝林|木|芶|秘|漢|軒|博|尋|開|蟻|續|曾林|郇|申屠|陳呂|記|檀|鬆|鄭黃|完|隗|寶|尉遲|老|埕|惲|台|庾|后|拾|俸|植|蒼|芎|咼|淡|党|團|卡|戢|懷|庹|陵|撤|多|荀|郟|示|考|定|瑪|蔚|職|郭黃||員|遊|慶|弓|郤|笪|蹇|罕|陀|送|欽|遇|果|長|學|乜||牙|宦|种|閃|倫|西|亞|拉|拓|豹|鴻|倉|財|智|儀|墨|隨|籍|火|業|縱|吳鄭|汝|猶|兆|伯|首|泰|魚|暢|賽|方鄒|波|堵|脩|淩|線|譙|司馬|洪許|岡|蚋|賁|雅|詩|銅|潛|蓮|繩|壬|牧|莎|祿|潭|闇|川|杲|振|央|竹|行|乳|凍|及|以|可|仵|拱|部|越|陳彭|乙|付|光|佐|昂|春|樟|祈|菰|幹|所|河|速|繞|黃沈|余楊|廖蔡|甫|府|思|崇|新|德|劉許|問|密|接|尼|瓦||乾|釧|淦|勝|貴|澎|類|夏侯|軒轅|劉范|莊吳|仁|吾|底|巷|是|旋|疏|僧|暴|賢|閭|蘆|代|先|院|吳游|介|化|仉|殳|把|里|呼|怯|迮|零|鍾張|劉郭|因|香|理|脫|圍|斐|萇|嘉|察|霄|汲|納|慎|遠|襲|弋|甲|回|洛|革|郅|宰|校|裔|樸|鎮|鮮于|曾江||後|娜|家|停|傳|槐|增|澹|隴|徐謝||正|局|勇|弭|揚|虢|糴|陳辜||朿|克|帖|度|要|茶|逢|弼|福|肇|雒|雛|索南|張趙||千|占|格|荷|答|補|粱|道|諾|穰|淳于|李梁|郭洪|孫林||百|順|運|端|蒿|蕢|優|籠||玄|杻|柑|眉|神|桃|浮|剡|喜|楮|電|睢|暨|賞|靜|令狐|胡周|朱吳|顓孫||加|希|飛|酒|菅|塘|義|藏|耀|戴楊||大|佃|拜|秧|寒|敦|樹|機|興|嶺|鎦|鐔|札西|康張|江周|張朱|||小|比|令|妙|具|彼|旺|皋|益|教|紫|萊|奧|節|緒|輝|翦|獨|鑑|沈游|東方|王顏|朱翁||列|合|治|奕|威|星|皇|苫|浣|斜|腰|嘎|憨|讓||札|名|夷|如|次|姒|泣|俎|偉|務|梨|犁|彪|提|塔|源|鉉|滾|磊|麗|露|邏|濮陽||一|攸|拔|桐|浩|豈|偶|敏|頓|嘺|彌|營|孫劉|陸費|連林||孑|天|心|旦|托|旮|佛|卲|受|固|板|況|者|雨|卻|洒|庫|茬|基|雪|凱|復|愛|碧|舞|劇|緱|鑾|土登|第五||凡|北|抄|枉|姥|省|美|胖|荒|荐|釗|旃|排|紹|傘|尊|善|聖|頊|監|維|緞|闖|騰|旦增|格桑|簡蕭|黃路||尢|丑|朮|臣|君|求|佡|羋|肯|芭|降|珠|紐|耕|陝|得|淳|清|莉|傑|棘|棗|猴|媽|歲|溥|圖|爾|銓|閰|審|稽|範|噶|舉|默|螘|禮|蕾|王易|薛林||士|中|守|有|姑|油|泊|娃|若|拿拿|真|假|啜|莘|筆|菲|閑|煙|貊|樵|積|縣|錫|鐘簡|白瑪|嚴林||上|扎|仕|句|弗|吏|汗|伋|宏|村|社|帕|拖|昆|沓|妲|厚|咪|彥|祕|茍|衍衍|迪|苖|邾|厙|恭|恩|扆|崗|淑|野|偰|揣|換|淵|琪|超|鄉|飽|筱|雎|漫|種|翡|潤|駒|薜|霞|甕|雞|繳|繼|鬱|袞桑|褚阮|益西|延陵||了|八|今|少|必|矢|立|朵|努|志|改|見|赤|制|奇|委|妮|朋|芙|邯|俄|係|珍|約|恒|埃|庭|效|起|剪|勒|將|渚|細|透|晴|逸|寋|督|號|賃|載|雋|竭|韶|禢|摩|潼|潮|嬴|澤|鄶|濱|濟|環|總|鍊|藤|騫|囊|靈|朱田|貢佈|扎西||丌|內|太|斗|本|目|旭|自|优|呈|吼|坊|坎|秀|伭|汶|奔|泥|知|芳|表|軋|非|俐|哇|恪|曷|柔|泉|祗|耐|苦|茂|迦|俉|奎|倚|島|徒|悅|桓|珮|珞|啊|堅|專|您|措|笛|第|荻|堀|閈|堪|湘|琴|結|意|椿|殿|瑞|群|誠|鉛|溤|演|睡|酸|遷|頡|養|撖|戲|黛|齋|瀨|璽|瓊|簫|證|礦|籐|辯|班森|于林||入|也|兀|勺|丐|允|刈|友|丙|且|叭|它|打|汀|卌|亦|伙|吁|佑|兌|呀|夾|妣|孝|孜|尾|每|玖|良|汴|刺|協|取|坤|岱|庚|性|或|舍|衫|邳|勃|契|姻|屋|恆|染|某|柒|呰|姞|昶|昜|訇|哲|娘|娟|娥|息|悟|扇|挪|烘|素|能|荏|迴|陜|鬥|袓|匙|參|曼|唱|圈|培|庶|晚|梵|梭|欸|淨|笙|軟|通|堤|壹|嵐|棠|琪|琺|琵|甦|硯|策|菜|跋|鈔|喏|羡|塞|廈|會|瑁|睦|肅|裟|該|詳|靶|葳|豋|僮|撤|歌|閥|閤|箂|鄚|蔤|儉|寬|憂|澄|潔|瑾|賡|褟|儒|導|憑|歷|璣|錦|霓|頭|錒|縮|霙|織|舊|黟|廬|簿|繡|霧|繨|羆|贇|藹|鐃|躍|曩|蘜|蘧|讀|曬|鸞|棋|于廖|旦巴|鍾巴|公羊|文樂|伊西|江田|班澤|"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)