re = /\b[\w.!#$%&’*+\/=?^`{|}~-]+@[\w-]+(?:\.[\w-]+)*\b/m
str = 'Matches an email address like john.doe@my-domain.com inside text
valid-email@email.com
not!valid@#email.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end