re = /^.*(?=.{6,})(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[!@#$%^&*? ]).*$/
str = '0341-86091234'
# Print the match result
str.match(re) do |match|
puts match.to_s
end