import re
regex = re.compile(r"<\/?\w+(\s+\w+=(['\"]).*\2)*\s*\/?\s*>", flags=re.MULTILINE)
test_str = ("<span>text</span>\n"
"<div style=''>text</div>\n"
"<div style=\"color:red;\">text</div>\n"
"<div style=\"color:red;\" titlt=\"title aaa\">text</div>\n"
"<div style=\"color:red;\" >text</div>\n"
"<br />\n"
"<你好>\n"
"<div title='\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")