$re = '/^[a-hj-npr-zA-HJ-NPR-Z]+$/m';
$str = 'test
tist
TEST
TIST
tost
tqst
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);