use strict;
my $str = '
<html>
<head>
<title>NFL Streams | NFL Live Streaming | NFLStreams Reddit - CrackStreams</title>
<meta name="keywords" content="live NFL streams, watch NFL Superbowl, NFL stream, nflstreams, nfl streams links, NFL score, NFL video">
<meta name="description" content="Watch NFL streams links with the best HD videos on the net for free - nflstreams reddit">
<meta charset="utf-8">
<meta property="og:title" content="NFL Streams | NFL Live Streaming | Football Online - CrackStreams" />
<meta property="og:description" content="Watch NFL streams links with the best HD videos on the net for free - nflstreams reddit" />
<meta property="og:site_name" content="Crackstreams - NFL" />
<link rel="canonical" href="http://crackstreams.com/nflstreams/">
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-133177581-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag(\'js\', new Date());
gtag(\'config\', \'UA-133177581-1\');
</script>
<link rel="stylesheet" href="/bootstrap3.min.css" media="screen">
<script src="/jquery.min.js"></script>
<script async src="/bootstrap.min.js"></script>
</head>
<body>
<nav class="navbar navbar-default">
<div class="container">
<div class="navbar-header">
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="navbar-brand" href="/">Crackstreams</a>
</div>
<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
<ul class="nav navbar-nav">
<li><a href="/nbastreams/">NBA streams</a></li>
<li><a href="/nflstreams/">NFL streams</a></li>
<li><a href="/cfbstreams/">NCAAF streams</a></li>
<li><a href="/mmastreams/">MMA/UFC streams</a></li>
<li><a href="/boxingstreams/">Boxing streams</a></li>
</ul>
</div>
</div>
</nav>
<div class="container">
<div class="row">
<div class="col-xs-12 text-center">
</div>
<div class="col-xs-12 col-md-8 col-sm-12">
<div class=\'clearfix\'><h1>NFL Network & Redzone</h1><hr></div>
<a href=\'http://crackstreams.com/nflstreams/nfltv/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Network</h4>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/redzone/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Redzone</h4>
</div>
</div> </a><br/>
<div class=\'clearfix\'><h1>NFL Live Streams and Schedule</h1><hr></div>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-cardinals-vs-ravens/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Cardinals vs Ravens</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-cowboys-vs-redskins/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Cowboys vs Redskins</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>(.+?)
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-colts-vs-titans/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Colts vs Titans</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-seahawks-vs-steelers/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Seahawks vs Steelers</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-bills-vs-giants/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Bills vs Giants</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-49ers-vs-bengals/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: 49ers vs Bengals</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-chargers-vs-lions/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Chargers vs Lions</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-vikings-vs-packers/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Vikings vs Packers</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-jaguars-vs-texans/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Jaguars vs Texans</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-patriots-vs-dolphins/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Patriots vs Dolphins</h4>
<p>September 15th, 2019 - 1:00 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-chiefs-vs-raders/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Chiefs vs Raiders</h4>
<p>September 15th, 2019 - 4:05 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-saints-vs-rams/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Saints vs Rams</h4>
<p>September 15th, 2019 - 4:25 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-bears-vs-broncos/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Bears vs Broncos</h4>
<p>September 15th, 2019 - 4:25 PM ET</p>
</div>
</div> </a><br/>
<a href=\'http://crackstreams.com/nflstreams/watch-nfl-streams-eagles-vs-falcons/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/nfl.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>NFL Regular Season Week 2: Eagles vs Falcons</h4>
<p>September 15th, 2019 - 8:20 PM ET</p>
</div>
</div> </a><br/>
</div>
<div class="col-xs-12 col-sm-12 col-md-4">
<div class="text-center">
</div>
<h2>Welcome to Crackstreams</h2>
<h4>Links are updated <b>ONE</b> day <b>BEFORE</b> the event. We offer NBA streams, NFL streams, MMA streams, UFC streams and Boxing streams. <br/><br/>
You can find us on reddit: r/mmastreams/, r/nbastreams, r/nflstreams, r/boxingstreams <br/>
<br/>
Please join our discord: <a href="https://discord.gg/xfScAtn">Discord Server</a>
<br/><br/>
Watch the NFL Preseason 2019 live stream from August 1st to August 29th.
</h4>
</div>
</div>
</div>
<hr>
<h2><b>What can I watch here?</b></h2>
<h4>You can watch NFL streams. We cover the NFL Preseason, Season aswell as the Playoffs.<br/>
Let\'s look at live NFL streaming. Want to watch your favorite team or player? Whenever it\'s the New England Patriots and Tom Brady or the Green Bay Packers and Aaron Rodgers, we have it all! </h4>
<br/>
<h2><b>How can I watch Free NFL Streams?</b></h2>
<h4>On this page you can see a list of events. Everything is listed by date and time. Scroll down the page and choose what you want to see and click on the Watch Now button. A new page opens on your browser with a screen. Simply click the play icon in the middle of the screen, then wait a second or two for the video to load. After a minute a chat will also open and you can talk with other NFL lovers or you can close the chat at any time. The screen can be maximized in the bottom right corner. Whatever device you watch on, whatever the size of the screen or wherever you are, we promise you great HD quality every time. And remember, you can click on the menu icon on the top right of the page and choose a category for more great live HD sport streams.</h4><br/>
<center>
<h4>
<b>Crackstreams will provide free live streaming:</b><br/><br/>
<li><a href="/nbastreams/">NBAstreams</a></li>
<li><a href="/nflstreams/">NFLstreams</a></li>
<li><a href="/mmastreams/">MMAstreams</a></li>
<li><a href="/boxingstreams/">Boxingstreams</a></li>
<li><a href="/mmastreams/">UFC streams</a></li>
</center></h4>
</body>
</html>';
my $regex = qr/class='media-heading.+?>(.+?):.+?(.+?)<.+\n.+?>(.+?)-.+?(.+?) /mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}