re = /^((?!\.doc).)*$/m
str = '256a5037-9fc1-4e60-95c3-523d5ae1c935/foo/44434038019,2019-05-24T09:02:18.695Z,b4786bf4-157a-4f1b-a030-4c5416e1884a
256a5037-9fc1-4e60-95c3-523d5ae1c935/bar/44434038019,2019-05-24T09:02:18.695Z,b4786bf4-157a-4f1b-a030-4c5416e1884a
govcorp/123a5037-9fc1-4e60-95c3-523d5ae1c935/foo/text.doc
156a5037-9fc1-4e60-95c3-523d5ae1c935/123a5037-9fc1-4e60-95c3-523d5ae1c935/foo/text.doc
123a5037-9fc1-4e60-95c3-523d5ae1c935/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end