import Foundation
let pattern = #"((1000)|([2][5]\d)|(([3456789]\d\d)))(?= {0,}(г|м))|(((?<=\D)[\d])|((0(.|,)[3456789][\d]))|([2][6789]))(?= {0,}(л|к))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0.26 кг
251 гр
Баранки Белицкие 400г.РБ
Белизна Российская Идеал 1000мл РФ
Вафли с аром.лесного ореха 1кг РФ
Вафли Фруктоша с корицей 1кг РБ
Вино Искорка пл,кр, 0,7л РБ
Вода мин, Минск-4 0,5л РБ
Жеват резинка Цветной язык 32,3гр РФ
Жевательная резинка с наполн Арбузики 32,3гр РФ
Зефир Панский с вар,сгущ, 1кг РБ
Йогурт для д/п Лесная ягода 2,6%мдж 207гр Беллакт
Карамель глаз с ликёрной нач Ясный месяц 1кг Украина
Карамель Дивная Даренка с начин.1кг РФ
Карамель со вкусом барбариса 1кг РФ
Каша б/приг Оригинальная 7 злаков 150гр РФ
Кефир обог.вит.Д3 пленка 1,6% 1л Савушкин РБ
Колбаса в/к Сервелат с паприкой в/с 390гр Комертекс
Колбаса вар Мортаделла 1с 1кг Ганна
Колбаса кровяная Шляхцецкая 1кг.Минск
Колбаса оригинальная Сервелат новый газ 1кг РБ
Консерва Треска с рисом и овощами 130гр Беллакт РБ
Конфета Лещина 1кг. Украина
Конфеты Cont&blue Клубника 1кг
Конфеты Ассорти 235гр РФ
Конфеты Тишка глаз вар сгущ/карам/возд рис (200гр) РФ
Конфеты Фруктовые забавы теплая вишня 1кг РБ
Конфеты шоколадные Assorted Chocolates асс 400гр Германия
Конфеты шоколадные Wamer Hudson ассорти 150гр Германия
Котлеты овощные заморож 360гр РБ
Кофе Якобз Монарх раств сублим 47,5гр РФ
Крекер Чипо с сыром 1кг. РФ
Маска Acme-Color д/всех типов волос 500мл Украина
Мороженое Птичье молоко Пломбир с аром сливочн крема 80гр РБ
не выбирать Ноги свиные 1кг.РБ
не выбирать Продукт из свин солен руб Акварель 1кг. РБ
не выбирать Продукт из свин.сол.руб. Акварель 1кг.РБ
Нектар Добрый абрикос 1л. РБ
Нектар Мультифруктовый 0,95л Оазис-Групп
Ноги свиные 1кг.РБ*
Ножка цыплёнка в панировке п/ф рубленый 1кг РФ
Ножка цыпленка в панировке рубленый (1кг) Россия
Носки женские 14С1300 р23-25 Брест
Овощи Весенние (зам) 400гр Санта РБ
ок томатный с мякотью и солью 3л Ляховичи РБ
Окорочок цыплёнка в панировке 1кн РФ
Окорочок цыплёнка в панировке п/ф рубленый 1кг РФ
П/Ф рубл Фарш Деревенский (1кг) БМК
П/Ф Сердце говяжье Селянское (зам) 1кг КМК
П/Ф Торетте с мясом и сыром из мяса/пт 430гр БМК
П/Ф Фарш рубл Деревенский (зам) соленый 1кг БМК
Палочки Stickletti original солёные 125гр Венгрия
Паштет Лакомка мясной запеч, терм,обр, 1кг РБ Брест
Пельмени Сочные вес.1кг. РБ
Перец фаршированный 1кг.РФ
Печенье LUKAS PALMIERS слоёное с изюмом 230гр Украина
Печенье сах Две стихии глаз 1кг Украина
Печенье Смуглянка 1кг Украина
Печенье Чайный Слодыч 1кг РБ
Пицца Калифорния мясное ассорти 330гр ПровитБел
Приправа универсальная 30г РБ
Прод плав с сыром колбасн копчен Буренкин 40% 1кг. РФ
Продукт из свинины Акварель руб.1кг.РБбрак
Пудинг Нежный ванильный 2,4% 115г.РФ
Салака копчено-провесная 250гр Санта
Сардина атл с доб масла 200гр Рыбарь РФ
Сардина атлант с добавл масла 200гр Рыбарь Россия
Сельдб кусок г/к в масле с ароматом дыма 500/350гр РБ
Сельдь атлант. с доб.масла ж/б 200гр РФ
Сельдь т/о крупн жирн сорт1 1*10 Россия
Семечки жар.без соли 190гр.РБ
Сервелат Барбадос фирменный в/к 1кгРБ Имперфуд
Смесь сухая NAN г/а Optipro-НА с 6-ти мес. Германия
Сметана 20%мдж 400гр Бабушкина крынка
Сметана 22% мдж 200гр Бабушкина крынка
Сметана 22%мдж 9плёнка) 400гр ММК
Сметана Свежие новости 22% 200гр (стакан) РБ
Сок Добрый абрикос2л. РБ
Сок Добрый ананас 2л. РБ
Сок Добрый мультифруктовый 2л. РФ
Сок Добрый тамат 2л. РБ
Сок Добрый томатный 1л. РБ
Сок Добрый яблоко 2л. РБ
Сок Добрый яблочный 1л. РБ
Сок Экзотик Томатный 1л. РБ
Соломка сладкая Pif-Paf 40гр РБ
Ср-во инсектицидное Дихлофос Варан А от насек,300мл Польша
Ср-во отбел, Бос-плюс maximum 600г РФ
Средство д/посуды Fairy Апельсин и лимонник 500мл РФ
Сухари с ванилином 1кг Минскхлебпром Беларусь
Сухарики Хрусteam со вкусом Баварские колбаски 90гр РФ
Сыр п/твёрд Сулугуни Granabella 45% в/у 240гр РБ
Сыр Сулугуни GRANABELLA 45%мдж 240гр Беларусь
Творог Деревенский биф/бак 2% 1кг. ММК
Творог зерн.Кали Ласка сливки 4% 140гр. ММК**************
Творог зерн.сливки 4% 230гр. ММК
торт Баловень 0,9 РБ Осиповичи
Торт Дарина 0,9 РБ Осиповичи
Фрутелла Ассорти клуб-апельс-лимон 41гр РФ
Халва Дружковская подсолн ванильная 80гр Украина
Хлеб Сяброуски 225г.Хлебпром
Чай Curtis Banana Flambe 1,8х20гр РФ
Чай зел Lipton Earl Grey 25*2 РФ
Чай ОК чёрный с аром земляники 20х1,5гр б/я РФ
Чай Хейлис чёрный, крупный лист 100гр РФ
Чай Хэйлис 1,5гр креп 100пак РФ
Чайм зел Липтон Грин 1,7*25пак РФ
Чипсы Онега вк, сметаны и лука 300гр РБ
Шоколад молочный с арахисом 90гр РФ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)