import re
regex = re.compile(r"(AB)\D*(\d+)\S*?(\d\d)\b(?=\s|[,'/]|-[A-Z]{2}\b)", flags=re.MULTILINE)
test_str = ("A='AB.224-QW-2018'\n\n"
"B='AB.876-5-LS-2018'\n\n"
"C='AB.26-LS-18'\n\n"
"D='AB-123-6-LS-2017'\n\n"
"E='IA-Mb-22L-AB.224-QW-2018-IA-Mb-22L'\n\n"
"F='ZX-ss-12L-AB-123-6-LS-2017-BC-22'\n\n"
"G='AB.224-2018'\n\n"
"H=''AB.224/QW/2018'\n\n"
"I=''AB/224/2018'\n\n"
"J='AB-10-HDB-231-NCLT-1-2017 AD-42-HH-2019'\n\n"
"K=''AB-1-HDB-NCLT-1-2016 AD-42-HH-2020'\n\n"
"L='AB-1-HDB-NCLT-1-2016/(AD-42-HH-2020)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")