package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]+)\/([0-9]+)\/([0-9]+)|((0?[1-9]|1[0-2])-(0?[1-9]|[12]\d|3[01])-(\d{4}|\d{2}))|\w+\s\d{2},\s\d{4}|(?i)\b(Jan(?:uary|\.)?|Feb(?:ruary|\.)?|Mar(?:ch|\.)?|Apr(?:il|\.)?|May|Jun(?:e|\.)?|Jul(?:y|\.)?|Aug(?:ust|\.)?|Sep(?:tember|\.)?|Oct(?:ober|\.)?|Nov(?:ember|\.)?|Dec(?:ember|\.)?)([ ](?:0?[1-9]|[1-2][0-9]|3[01]),?[ ]|-(?:0?[1-9]|[1-2][0-9]|3[01])-)(\d{4})`)
var str = `Mar 7, 2017
Mar. 7, 2017
March 7, 2017
3-7-2017
03-07-2017
3-7-17
03-07-17
03/7/2017
03/07/17
3/7/17
Mar-07-2017
Mar-7-2017
March-07-2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}