import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s\\S]{25}(?<log_level>\\w+ \\d).---.\\[Thread-(?<thread_id>\\d+)][\\s\\S]{42}(?(?=: debug1): (?<internal_log_level>\\w+)): (?(?=(?:.*?): )(?<module>.*?): )(?<message>.*)";
final String string = "2020-03-24 07:23:26.506 INFO 6 --- [Thread-3853] S.s.ssh-output : Allocated port 40239 for remote forward to localhost:8192\n"
+ "2020-03-24 07:23:26.458 INFO 6 --- [Thread-3853] S.s.ssh-output : Authenticated to tunnel.alero.io ([3.225.55.134]:443).\n"
+ "2020-03-24 07:23:25.972 INFO 6 --- [Thread-3853] S.s.ssh-output : OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n 7 Dec 2017\n"
+ "2020-03-24 07:22:55.949 INFO 6 --- [Thread-3851] S.s.ssh-output : ssh_exchange_identification: Connection closed by remote host\n"
+ "2020-03-26 14:50:11.591 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 1: connected to localhost port 8192\n"
+ "2020-03-26 14:50:11.591 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: confirm forwarded-tcpip\n"
+ "2020-03-26 14:50:11.591 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 1: new [192.168.33.160]\n"
+ "2020-03-26 14:50:11.591 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: connect_next: host localhost ([127.0.0.1]:8192) in progress, fd=5\n"
+ "2020-03-26 14:50:11.589 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: client_request_forwarded_tcpip: listen 0.0.0.0 port 40239, originator 192.168.33.160 port 37440\n"
+ "2020-03-26 14:50:11.589 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: client_input_channel_open: ctype forwarded-tcpip rchan 2 win 2097152 max 32768\n"
+ "2020-03-26 14:50:11.372 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 0: connected to localhost port 8192\n"
+ "2020-03-26 14:50:11.372 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: confirm forwarded-tcpip\n"
+ "2020-03-26 14:50:11.372 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 0: new [192.168.62.96]\n"
+ "2020-03-26 14:50:11.372 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: connect_next: host localhost ([127.0.0.1]:8192) in progress, fd=4\n"
+ "2020-03-26 14:50:11.372 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: client_request_forwarded_tcpip: listen 0.0.0.0 port 40239, originator 192.168.62.96 port 59736\n"
+ "2020-03-26 14:50:11.372 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: client_input_channel_open: ctype forwarded-tcpip rchan 1 win 2097152 max 32768\n"
+ "2020-03-26 14:50:10.872 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 0: free: 192.168.62.96, nchannels 2\n"
+ "2020-03-26 14:49:11.329 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 0: connected to localhost port 8192\n"
+ "2020-03-26 14:49:11.329 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: confirm forwarded-tcpip\n"
+ "2020-03-26 14:49:11.329 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 0: new [192.168.62.96]\n"
+ "2020-03-26 14:49:11.329 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: connect_next: host localhost ([127.0.0.1]:8192) in progress, fd=4\n"
+ "2020-03-26 14:49:11.328 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: client_request_forwarded_tcpip: listen 0.0.0.0 port 40239, originator 192.168.62.96 port 58296\n"
+ "2020-03-26 14:49:11.328 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: client_input_channel_open: ctype forwarded-tcpip rchan 1 win 2097152 max 32768\n"
+ "2020-03-26 14:49:10.875 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 0: free: 192.168.33.160, nchannels 2\n"
+ "2020-03-26 14:49:03.819 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 1: free: 192.168.33.160, nchannels 3\n"
+ "2020-03-26 14:48:49.820 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 8: free: 192.168.62.96, nchannels 4\n"
+ "2020-03-26 14:48:49.820 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 7: free: 192.168.62.96, nchannels 5\n"
+ "2020-03-26 14:48:49.820 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 5: free: 192.168.33.160, nchannels 6\n"
+ "2020-03-26 14:48:49.819 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 3: free: 192.168.33.160, nchannels 7\n"
+ "2020-03-26 14:48:49.819 INFO 6 --- [Thread-3853] S.s.ssh-output : debug1: channel 2: free: 192.168.33.160, nchannels 8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}