import re
regex = re.compile(r"([\s\S].*?)\b((?:\s*\d+\s+;?|\s*\d+;)PAGE\s+\d+|\s*PAGE.*[0-9])", flags=re.MULTILINE)
test_str = ("FREE SOFT FOUNDATION V2 1989 PAGE 2\n"
"STALLMANWORKS 2000 1977;PAGE 2\n"
"THE GNU PAGE 3 1977")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")