package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[{,%]?(?<fieldName>.+)(\((?<fieldId>\d+)\))?[},%]?\]`)
var str = `[FieldName(5454)]
[{FieldName}]
[{FieldName(5454)}]
[%FieldName(5454)%]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}