package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\'{3}(?:[^\\]|\\[\s\S])*(?:\'{3}$))`)
var str = `''' 'This "is" my' && "first 'regex' sentence." '''
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}