# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=\"(?!(?:/get/index\.php|\S*/PICSNUM/))([a-z0-9-_\/.]+)"
test_str = "<a href=\"/video5505298733/travel_and_tourism_recovery_coronavirus.\" title=\"The places and companies missing tourist dollars most.\">The places and companies missing tourist dollars most.</a></p><p class=\"info\"><span class=\"bg\"><span class=\"duration\">10 min</span><a href=\"/get/index.php?id=qafMsaaScGLPuKqGuanBpZjHtGHKppeHpJu5r6G9raaHoqa3tJS-ope5tJK6s5TLqp8\"><span class=\"name\">CORONAVIRUS</span></a><span><span class=\"bolder\"> - </span> 1.7k <span class=\"bolder\">Views</span></span><span class=\"text-disabled\"><span class=\"bolder\"> - </span> 2 days ago</span><span class=\"bolder\"> - </span></span></p></div></div> <div class=\"thumb-lock \"><div class=\"thumb-big\"><div class=\"thumb\"><a href=\"/midia54891337/PICSNUM/russia_fire_coronavirus_patients_intl\"><img src=\"lightbox.gif\" data-src=\"https://cdn-pic.cnews-cdn.com/videos/thumbs169/22/d3/a2/22d3a23423dfda7f5/22d3a2dfbb9fdfgd43f5.PICNUM.jpg\" /></a>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.