$re = '/^\d+(,\d+)?$/m';
$str = '11
11,11
11.11
-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);