$re = '/(?<=^|\s)([A-Z\d]{5}\-){4}([A-Z\d]{5})(?=$|\s)/';
$str = 'V2C47-MK7JD-3R89F-D2KXW-VPK3J';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);