re = /<a\s+\[monitory\]\s+href=["'](https?:\/\/.*?)["']\s*>/m
str = '<a [monitory] href=|http:/www.teste.com|>
<a [monitory] href=|http://www.teste.com|>
<a [monitory] href="http://www.teste.com">
<a [monitory] href="http://www.link1.com"><a [monitory] href="http://www.link2.com">
<a [monitory] href="http://">
<a [monitory] href="http:///#@$@$@$@#">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end