$re = '/^(?:.{0}|.{4}|.{7}|.{8})([A-Z])(?:.{1}|.{3}|.{6}|.{9})([0-9])$/';
$str = 'A11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);