import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\\!-\\/\\:-\\@\\[-\\`\\{-\\~])(?:.{8})$";
final String string = "*** NOT MATCH\n"
+ "abc\n"
+ "abc123\n"
+ "abC12312\n"
+ "123Abc!!d\n"
+ "*** MATCH\n"
+ "1Ab@1Ab@\n"
+ "%D123!cc\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}