import re
regex = re.compile(r"\$([\w]+)->([^\W]+)")
test_str = (" @foreach($fsn_uploaded_data as $client_no => $client)\n"
" <div class=\"client\" style=\"border: 1px solid #888; margin-bottom: 10px;\">\n"
" <h2>{{ $client['client_name'] or '-' }}</h2>\n"
" <p>{{ $client->postal_address or '-' }}, {{ $client->zip_code_postcode or '-' }}, {{ $client->city or '-' }}, {{ $client->countr_code or '-' }}</p>\n"
" }\n\n"
"{{-- @foreach($client->delivery_addresses as $delivery_no => $address)\n"
" <div class=\"delivery_addresses\" style=\"border: 1px solid #ddd; margin: 5px;\">\n"
" <h3>{{ $address->client_delivery_name or '-' }}</h3>\n"
" <p>{{ $address->delivery_address or '-' }}, {{ $address->zip_code or '-' }}</p>\n"
" </div>\n"
" @endforeach --}}\n"
" </div>\n"
" @endforeach")
subst = "$\\1['\\2']"
result = regex.sub(subst, test_str)
if result:
print(result)