$re = '/[1-9]\d{3,}-[1-9]\d{1}-[1-9]\d{1}/';
$str = '2016-00-00
2015-10-20
2015-12-23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);