# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<host>\d+\.\d+\.\d+\.\d+)\s*-\s*(?P<user_name>[^\s-]*?)\s"
test_str = ("189.254.43.43 - swift6867 [21/Jun/2019:15:53:00 -0700] \"GET /architectures/recontextualize/morph/scale HTTP/1.0\" 204 8976\n"
"20.80.28.12 - hagenes4423 [21/Jun/2019:15:53:01 -0700] \"POST /harness HTTP/1.1\" 404 28127\n"
"112.211.50.38 - - [21/Jun/2019:15:53:03 -0700] \"DELETE /harness/e-business/functionalities HTTP/1.1\" 405 7975")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.