re = /\((.*?),/m
str = '[(net, asset), (amount, asset), (connect, asset), (net, asset), (check, asset), (service, asset), (adapt, asset)] | [(part, asset)]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end