import Foundation
let pattern = #"(?<=\")(\s)(?=\w)|(?<=\w)(\s)(?=\")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"assessmentID": 289,
"assesmentName": " OneCert ",
"accountName": " spadmin ",
"assetName": " OneCert ",
"applicationName": " OneCe rt ",
"accountType": " LocalAccount ",
"environment": " Test "
},
{
"assessmentID": 289,
"assesmentName": "OneCert ",
"accountName": "9000032",
"assetName": "OneCert",
"applicationName": "OneCert ",
"accountType": "zone2.scbdev.net",
"environment": "Test"
},
{
"assessmentID": 289,
"assesmentName": "OneCert ",
"accountName": "9000032",
"assetName": "OneCert",
"applicationName": "OneCert ",
"accountType": "zone2.scbdev.net",
"environment": "Test"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)