$re = '/^[M-Y]/m';
$str = 'XML Advanced
Learning XPath
DTD
XSLT Professional
Xquery
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);