package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:qwe\b\s+abc|(abc))\b`)
var str = `qwe abc
qwe abc
abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}