$re = '/\d\d/\d\d/\d\d\d\d \d\d:\d\d:\d\d\.\d\d\d/';
$str = '03/27/2016 07:58:17.442 U:Event: Current Process Recipe Name = PFCA-800Pulse.prc [LLA_01] [2016-03-27_003_A1B]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);