package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-z]+\\\\[a-z0-9]+$`)
var str = `domain\\user001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}