# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@@colored:(.*?) @color:(.*?)@@"
test_str = ("some text @@colored:South Africa, officially the Republic of South Africa, is the southernmost country in Africa. It is bounded on the south by 2,798 kilometers of coastline of southern Africa stretching along the South Atlantic and Indian Oceans on the north by the neighbouring countries of Namibia, Botswana and Zimbabwe, and on the east by Mozambique and Swaziland, and surrounding the kingdom of Lesotho.[12] South Africa is the 25th-largest country in the world by land area, and with close to 53 million people, is the world's 24th-most populous nation. @color:red@@ another text\n")
subst = "<p style='color:$2;'>$1</P>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.