package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\$?[\d.\,]\s*)(\$|руб|грн|р)?`)
var str = `$100 $
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}