re = /^(0[1-9]|[12][0-9]|3[01])-(0[1-9]|1[012])-(19|20)\d\d$/
str = '22-05-2015'
# Print the match result
str.match(re) do |match|
puts match.to_s
end