$re = '/{if ([a-z0-9:]{3,20}) ([\=\=|>|<|\!\=]{1,2}) ([0-9a-z]{1,20})}(.*?){else}(.*?){endif}/s';
$str = '...
{if var > 0}
тут хтмл код
{else}тут другой хтмл код
{endif}
.....
{if id < 6}тут хтмл код{else}тут другой код{endif}
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);