import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?!\\b-\\b|-\\b)(?:.|^))\\b(\\d{4})\\b";
final String string = "2014\n"
+ "1106 **2014** **9899** \n"
+ "**11500**\n\n"
+ "234-233-2014\n"
+ "234-234-1100\n"
+ "-1100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}