using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:http(?:s?)://)?(?:www\.)?vk\.com/video)(?:\?z=video)?(-?\d{5,}_\d{5,})";
string input = @"https://vk.com/video-23213239_171659525";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}