$re = '/huurprijs\s+€([.\n\d\s\w\S]+)/m';
$str = 'De : benelux@bungalow.eu <benelux@bungalow.eu>
Envoyé : mercredi 29 juillet 2015 10:55
À : PVCP, CCCsupport NL; benelux@bungalow.eu
Objet : BEVESTIGING VAN UW RESERVERING [LAST MINUTE] Reserveringsnummer: THFCH4 Bevestiging reservering voor uw woning Wij willen u vragen hierbij de ontvangst van deze reservering voor de desbetreffende huurprijs en periode aan ons te bevestigen, door op de onderstaande link te klikken. Vermijd problemen, houd uw kalender goed bij. Het is uw verantwoordelijkheid als verhuurder om de prijzen en beschikbaarheid actueel te houden. Mocht er onverhoopt in onderstaande boeking een verschil in prijs en/of beschikbaarheid zijn, neemt u dan alvorens te bevestigen contact op met uw accountmanager. Nadat u op onderstaande link geklikt heeft, worden de reisdocumenten aan de huurder gezonden, wij vragen u daarom z.s.m. uw reservering(en) te bevestigen. Alvast bedankt!
Klikt u hier om te bevestigen. Klik hier om te annuleren
Gegevens huurder: Naam: Dhr. Frank Wissels Land waar u woont: Nederland Aankomst: 3 augustus 2015 Vertrek: 17 augustus 2015 Gegevens reservering: Accommodatie: [BN903456] TF956 Premium Eden 8
Hattigny Frankrijk,
tot 8 personen Samenstelling reisgezelschap: 1 Baby\'s t/m 2 jaar
2 Kinderen van 5 t/m 12 jaar
2 Volwassenen van 21 t/m 49 jaar
Extra services: Voorkeursligging
Kinderdekbedpakket 2 personen
Handdoekenpakket 5 personen
Dekbedpakket 2 personen
Keukenpakket
Uw opmerkingen Rebooked from QZU3YK Uw opbrengsten: Uw huurprijs € 3808.00 Toeristenbelasting: 118.30 Voorkeursligging 66.00 Kinderdekbedpakket 19.00 Handdoekenpakket 30.00 Dekbedpakket 16.00 Keukenpakket 5.50 Onze commissie: € -609.80 Uw opbrengsten:: € 3453.00 Ter plaatste betalen aan verhuurder Totaal: €0.00 Totaalbedrag
€ 4062.80';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);