// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:http|ftp)s?:\/\/([\w][^\/=\s]+)\/?|(^w{3}[\.\w][^\/\=\s]{2,})\/?").unwrap();
let string = "www.google.com.edu-hjj+oio?/kjhkh.txt hjjh
https://calendar.google.com/calendar/render?tab=ic&pli=1#main_7
http://www.yahoo.comhttp://www.yahoo.co
www.foo.com.ui/=hjg.hhj
ggfhgfhfhf.uui
https://regex101.com/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}